I thought I'd post a little clarification. This solution worked great for me, but the typos to which some of the discussion has alluded were a huge inconvenience, and if you're like me (little bash experience, just trying to save a trip to the Apple store), it will take hours of experimentation to get the commands right. Everything is fine until step 2.

Quote:
2) mount the comboupdate DMG image; type:
hdiutil /Volumes/External HDD/MacOSXUpdCombo10.4.10Intel.dmg

This is missing the verb ("attach"). Also (and this applies every time you specify a path) any time the path contains a space or a parenthesis, you must place a backslash ("\") immediately before the space or parenthesis. Thus, the command that worked for me was (without the quotations marks):

"hdiutil attach /Volumes/My\ Passport/MacOSXUpdCombo10.4.11Intel.dmg"

where /Volumes/My\ Passport is the path to my external hard drive and MacOSXUpdCombo10.4.11Intel.dmg is the filename of my combo update.

Moving on...


Quote:
4) install the new update
/Volumes/Internal\ HDD/usr/sbin/installer -pkg /Volumes/Mac\ OS\ X\ 10.4.10\ Combined\ Update...pkg -target /Volumes/Internal\ HDD

This was the step that sucked all my time. The given path is incomplete - it specifies the directory of the installer package, but doesn't specify the package itself. In other words, the given path is missing the chunk that has the form "MacOSXUpdCombo10.4.11Intel.pkg". The path that worked for me was (again, don't enter the quotation marks):

"/Volumes/Macintosh\ HD/usr/sbin/installer -pkg /Volumes/Mac\ OS\ X\ 10.4.11\ Combined\ Update\ \(Intel\)/MacOSXUpdCombo10.4.11Intel.pkg -target /Volumes/Macintosh\ HD"

where MacOSXUpdCombo10.4.11Intel.pkg is the filename of your comboupdate and the extension .pkg. Note that every space and parenthesis (and any other character that bash is programmed to interpret as special) requires a "\" immediately before it.

I hope this helps. For reference, here is a site with some bash terminal command explanations http://www.ss64.com/osx/ .

Good luck!

FKenton